X9 Owners & Riders Club

The X Files ~ The Piaggio X Series => X9 Specific Stuff => Topic started by: zaf13 on January 29, 2019, 08:05:30



Title: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on January 29, 2019, 08:05:30
Goodmorning to the forum!
I have a problem with my x9 180, I was riding and suddenly the scooter shuted off! No power at all, nothing, dead! I checked the fuses under seat, second from top (if I rember right, I will check again) was blow off, I changed and blows off instantly, even without key on ignition!! Any advice?


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on January 29, 2019, 15:31:57
This type of fault is usually caused by a worn through bit of wiring somewhere. If it went while riding, something has probably nipped or chafed through a part of the loom somewhere. The only way to find it is to strip off all the plastics and examine along all the wiring looking for damage.
What does that fuse supply exactly? Check around these areas first.


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: allen m on January 29, 2019, 21:43:56
Hi
I agree with Dave. Sounds like damaged cables.
One extra point I would add is proceed slowly and carefully looking for trapped and/or damaged wires. If you go mad, tugging at everything it is possible, if the insulation is damages and shorting to the frame to move it and then not find a fault.  Put everything back together, ride for a while, the damaged cable shorts again,  - - - you know what I mean.
Been there, don that :headbang:
Regards
Allen Morgan


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on January 30, 2019, 10:16:36
Thank you guys for your answers, I will strip it down to check the wiring loom, I will update when I find the problem


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: bustupbiker on January 30, 2019, 16:43:29
Thank you guys for your answers, I will strip it down to check the wiring loom, I will update when I find the problem

Zaf, as said what does this fuse control? 


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on January 30, 2019, 18:54:44
Going off the owners manual for 125-250 models:
Fuse No. 1
Position on fuse holder:1
Capacity: 15A
Protected circuits: 12V-180W
Socket for electrical equipment -
Helmet compartment light -
Electrical saddle opening -
Antitheft device pre-installation
Location:helmet compartment

Fuse no. 2
Position on fuse holder: 2
Rating: 15A
Protected circuits: Radiator
electric fan - Battery recharging
circuit - Vehicle's lights - Antitheft
system pre-wiring voltage supply -
Electrical lines protected by fuses
4, 5, 6, 7, and 8
Location:helmet compartment

Fuse No. 3
Position on fuse holder: 3
Capacity: 10 A
Protected circuits: High- and lowbeam
lights - Front and rear tail
lights - License plate bulb
Location:helmet compartment

Fuse No. 4
Position on fuse holder: 4
Capacity: 7.5 A
Protected circuits: Power for
radio/intercom control unit preinstallation
- Analogue indicator
Location:helmet compartment

Fuse No. 5
Position on fuse holder: 5
Capacity: 7.5 A
Protected circuits: Headlight
warning light - Front and rear tail
lights - License plate light
Location: front case

Fuse No. 6
Position on fuse holder: 6
Capacity: 10 A
Protected circuits: Digital
instrument panel - Immobilizer
LED
Location: front case

Fuse No. 7
Position on fuse holder: 7
Capacity: 10 A
Protected circuits: High-beam
bulb and warning light in "passing"
- Horn - Power for accessories preinstallation
Location: front case

Fuse No. 8
Position on fuse holder: 8
Capacity: 7.5 A
Protected circuits: Stop lights -
Vehicle start-up enabling button -
Power for radio/intercom control
unit pre-installation and antitheft
device installation
Location: front case


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on January 31, 2019, 06:12:32
Number 2 fuse!


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on January 31, 2019, 08:10:42
Well it would be one of the other 5 fuses 4, 5, 6, 7, and 8 if the fault was on any of those circuits assuming the fuse values on these are normal, so that leaves Radiator electric fan - Battery recharging circuit - Vehicle's lights - Antitheft system.

Do you have an alarm in which case my money is on that.


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on January 31, 2019, 11:39:02
Well it would be one of the other 5 fuses 4, 5, 6, 7, and 8 if the fault was on any of those circuits assuming the fuse values on these are normal, so that leaves Radiator electric fan - Battery recharging circuit - Vehicle's lights - Antitheft system.

Do you have an alarm in which case my money is on that.

No I don't have alarm on it, there was a problem with starter relay Last days, the relay wanted a litle knock to unstuck and start the bike, is there any posibility that relay cause some kind of sorting? ( sorry for my english 😂)


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on January 31, 2019, 12:40:48
Possibly. Unplug it and see if the fuse blows without it.


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on February 02, 2019, 10:36:39
Its not the starter relay, lets get to work with these wires 😂


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Peter T on February 05, 2019, 22:09:50
If the loom is similar to the 250, try the branch under the tunnel just behind and to the left of the petrol tank

In bocca al lupo


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on February 10, 2019, 14:41:47
https://imgur.com/a/5wAtlGg  (https://imgur.com/a/5wAtlGg)

With the multimeter tested, seems like the wire sort with ground,am i right?


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Peter T on February 10, 2019, 15:29:40
Just tried your test on my 250 evo on which everything works, it shows high resistance (33k) to earth. When I plug the fuse back in, there is a solenoid whirr (noise) from the front end.


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on February 10, 2019, 15:30:45
No fuse should be to ground. There should be a quite high resistance depending on what the circuit is it's feeding.


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on February 10, 2019, 15:32:05
So if the noise is from the front, is it from the dash? If so then investigate under the handlebar covers behind the digidash and also up the hedstock where the loom into the handlebars is clipped.


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Peter T on February 10, 2019, 15:42:43
So if the noise is from the front, is it from the dash?

Just had another check. It's the analogue dash waving its hands about. But that's beyond the front fuse box so the weaker fuses there would blow first would they not?


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on February 11, 2019, 07:40:04
I don't have power at all, when connect the battery the fuse blows instant!


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on February 11, 2019, 07:55:47
Back to a chafing issue on the loom then somewhere.
Use your test meter set on audible resistance and between the fuse output side and ground then see if you can find the point where the noise stops when you move the loom. Turn the steering as the loom is under most strain where it comes up the headstock and through the plastic guide below the handlebars then where it splits to the switches and dash.


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on February 18, 2019, 13:01:20
I remove the digidash and the bike works fine, no blowing fuse, I opened the digidash and its fried inside, I will post phitos


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Dave Milnes on February 18, 2019, 13:55:12
Luckily 125/180/200 digidashes are not too hard to come by on Ebay.
https://www.ebay.co.uk/itm/PIAGGIO-X9-125-2004-CLOCKS-SPEEDO-DIGITAL-DISPLAY-2876-MILES-BOX/254125433764?hash=item3b2b0e63a4:g:jtEAAOSwuJlcZreg:rk:48:pf:0


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Peter T on February 18, 2019, 14:56:46
Pleased you found the problem. Good luck finding a new dash  :)


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: Mike H on February 18, 2019, 16:58:18
Where are photos?


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on February 18, 2019, 17:40:39
https://imgur.com/a/FoG7SBK


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: unchained on February 18, 2019, 21:57:18
That doesn't look healthy!

If you have a problem locating a replacement dash, that does look like it could be repaired by someone with the correct knowledge and equipment.

Bob


Title: Re: X9 180 shuted off, no power, blows fuse
Post by: zaf13 on February 20, 2019, 05:38:08
That doesn't look healthy!

If you have a problem locating a replacement dash, that does look like it could be repaired by someone with the correct knowledge and equipment.

Bob

Yes, I will try to find someone to fix, here at Greece costs 80euro used.